解決asp.net出現這個專案的目標是ASP.NET 2.0;如果不設定,某些功能可能無法正確運作

解決asp.net出現這個專案的目標是ASP.NET 2.0;如果不設定,某些功能可能無法正確運作(查看次數:122)

回首頁

2016-10-28 11:15:33
用vs2013開啟網站出現"站台 ‘http://localhost/’ 目前是設定成配合新版的 ASP.NET(4.0)使用。這個專案的目標是ASP.NET 2.0;如果不設定,某些功能可能無法正確運作,而且使用這項工具設計的頁面也可能無法正確呈現。是否要將此站台設定成配合 ASP.NET使用?",上次用是,網站開不起來,但是每次開都會出現這個畫面,用記事本是開啟xxx.sln,發現TargetFrameworkMoniker = ".NETFramework,Version%3Dv3.5",是版本3.5,但是訊息跟我說是2.0,我把它改成4.0,再開啟專案,就可以正常,最後又改成3.5,想看看在圖形介面要如何修改,結果又出現另一個問題,就是開啟專案會出現"ASP.NET 4.0 尚未在 Web 伺服器上註冊",下次再來找這個問題。

asp_et_version_01
1.出現專案目標不同的訊息,選【否】


asp_et_version_02
2.有些控制項會出現錯誤


asp_et_version_03
3.點選【網站】右鍵/【屬性質】


asp_et_version_04
4.將目標framework由3.5改成4.0/【確定】




asp_et_version_06
5.【是】


asp_et_version_07
6.出現另一個錯誤【ASP尚未在web伺服器上註冊】/【確定】


asp_et_version_08
7.剛剛不能出現的功能選單正常了


解決asp.net出現這個專案的目標是ASP.NET 2.0;如果不設定,某些功能可能無法正確運作
上一篇:商店(326)      下一篇:excel的vlookup如何利用輔助欄位來查詢多欄位條件(49)